Ivona's blog

Just another WordPress.com site

Eliminarea unor cifre din numar Noiembrie 20, 2010

Filed under: Informatica — ivonachili @ 6:43 pm

Eliminarea unor cifre din numar

 

1.Enunt: 

Se da un numar natural n.Sa se elimine din numar cifrele prime.

 

2.Exemplu:

n c p m
835476 6 10 6
83547 7    
8354 4 100 46
835 5    
83 3    
8 8 1000 846

 

 

 

 

 

m=m+c*p

p=p*10

 

3.Pseudocod:

 

Citeste n

P=1

M=0

Cat timp n!=0 executa

         C=n%10

        N=n/10

       Daca c!=2&&c!=3&&c!=5&&c!=7 atunci

                                                          M=m+c*p

                                                          P=p*10

Scrie m

 

Minim.Maxim

Filed under: Informatica — ivonachili @ 6:31 pm

MINIM.MAXIM

 

1.Enunt:

 

Se da un numar natural n.Sa se afiseze cea mai mare cifra a numarului.

 

2.Exemplu:

 

n c max
14836 6 6
1483 3  
148 8 8
14 4  
1 1  
0    

 

3.Pseudocod:

 

Citeste n

Max=0

Cat timp n!=0 executa

                     C=n%10

                     N=n/10

                    Daca c>max atunci max=c

Scrie max

 

Oglinditul unui numar

Filed under: Informatica — ivonachili @ 6:19 pm

 OGLINDITUL UNUI NUMAR

 

1.Enunt: 

Se da un numar natural n.Sa se afiseze oglinditul numarului.

 

2.Exemplu:

 

n=1472

 

n c ogl
1472 2 2
147 7 27
14 4 274
1 1 2741
     

 

Ogl=ogl*10

 

3.Pseudocod:

 

Citeste n

Ogl=0

Cat timp n!=0 executa

           C=n%10

           N=n/10

          Ogl=ogl*10+c

Scrie ogl

 

 

Cifrele unui numar

Filed under: Informatica — ivonachili @ 5:50 pm

CIFRELE UNUI NUMAR 

 

1.Enunt:

 

Se da un numar natural n.Se cere sa se afiseze cifrele numarului.

 

2.Exemplu:

 

 n c
1472 2
147 7
14 4
1 1
0  

n=1472;

 

 

 

c=n%10=1472%10=2;

n=n/10=1472/10=147;

 

c=n%10=147%10=7;

n=n/10=147/10=14;

 

c=n%10=14%10=4;

n=n/10=14/10=1;

 

c=n%10=1%10=1;

n=n/10=0

 

3.Algoritm:

 

٭Se citeste numarul;

٭Cat timp n!=0 executa

         -aflam ultima cifra(c=n%10)

        -eliminam ultima cifra(n=n/10)

       -afisam c (cifra)

 

4.Pseudocod:

 

Citeste n

Cat timp n!=0 executa

C=n%10

N=n/10

Scrie c

 
 
 

5.OBSERVATII:

 

1.Numarul n se modifica;

2.Cifrele numarului se afla in ordine inversa;

3.Pentru a folosi numerele in continuare trebuie sa se faca copii;

 

Noiembrie 14, 2010

Filed under: Inventii — ivonachili @ 7:37 pm

Japonezii isi exerseaza instinctele parintesti pe un robot-bebelus

Cercetatorii japonezi au creat un robot ce imita comportamentul unui nou-nascut si interactioneaza cu oamenii, la fel ca un copil adevarat.

Robotul Yotaro stie sa zambeasca daca te joci cu el sau il mangai, insa va incepe sa planga ca orice bebelus, daca il sacai asu daca il bruschezi, transmite AFP.

„Yotaro este un robot cu care va puteti purta la fel ca si cu un bebelus adevarat, iar el va reproduce senzatiile copilului nou-nascut”, spune Hiroki Kunimura, unul dintre cercetatorii laboratorului de robotica si stiinte comportamentale al Universitatii Tsukuba.

Robotii umanoizi cuceresc lumea (Galerie foto)

Fata lui Yotaro este realizata din silicon translucid, cu o nuanta de roz, luminat din interior de un proiector ce simuleaza reactiile unui copil care plange, stranuta, doarme sau zambeste.

De asemenea, un difuzor instalat in interiorul robotului emite sunetele toate corespunzatoare starilor sufletesti ale bebelusului artificial.

Robotul isi schimba expresia fetei si isi misca mainile si picioarele cand este atins in diferite zone ale corpului.

3 motive pentru care ar trebui sa ne temem de roboti

Atingerile sunt detectate de senzori raspanditi in tot corpul sau, iar reactiile robotului sunt influentate inclusiv de frecventa acestora.

Mai mult, lui Yotaro ii poate curge si nasul, cu ajutorul unei mici pompe ce elibereaza picaturi de apa, prin nari.

Capul sau seamana mai degraba cu un balon, iar trasaturile faciale sunt exagerate, insa… mai mult.

Robotul-manechin, in curand pe podiumuri

Cercetatorii japonezi au dezvaluit, luni, primul robot care va prezenta moda pe un podium din Tokyo.

Robotul, un umanoid cu ochii mari, nas mic si o tunsoare pana la umeri, este dotat cu 42 de motoare de miscare, care ii permit sa imite orice miscare a unui manechin uman, informeaza Breitbart.

„Buna ziua tuturor, eu sunt omul cibernetic HRP-4C”, s-a prezentat robotul-manechin in fata jurnalistilor stransi la National Institute of Advanced Industrial Science and Technology din Tokyo.

Instruit de jurnalisti printr-un dispozitiv bluetooth, cyborg-ul a facut mai multe miscari specifice prezentarilor de moda, a pozat, si-a tuguiat buzele si a zambit larg. La 23 martie, va avea ocazia sa-si demonstreze calitatile intr-o prezentare de moda adevarata.

Robotul are 158 de centimetri in inaltime (media femeilor japoneze) si cantareste 43 de kilograme, cu baterii cu tot.

Are un chip inspirat din benzile desenate manga si un corp metalic.

„Daca am fi facut un robot prea asemanator cu oamenii, ar fi fost o situatie neconfortabila. L-am facut in mod deliberat in stilul benzilor desenate”, a explicat unul dintre creatorii robotului, Shuji Kajita.

La fel ca si „colegele” sale umane, robotul are un pret piperat: cercetatorii au cheltuit 2 milioane de dolari pentru constructia sa.

Fetita-robot, creata in Japonia

La sfarsitul acestei saptamani, pe piata japoneza va iesi fetita-robot, Repliee R-1, un umanoid creat dupa chipul si asemanarea unei fetite de cinci ani.

Scopul crearii omului artificial in miniatura este numarul mare de varstnici din Japonia, care au nevoie de asistenta sau de un insotitor, relateaza The Sun.

Pentru ca fetita-robot sa aiba un aspect cat mai realist, oamenii de stiinta de la Univesritatea Tsukuba au folosit piele flexibila din silicon. Repliee R-1 are 50 de senzori si o serie de motoare care o ajuta sa se miste si sa reactioneze la stimulii din jur. Constructorii au inzestrat-o chiar si cu capacitatile de a respira si de a clipi.

Compania Cyberdyne Inc va incepe sa o produca in masa de vineri.Fetita-robot, creata in Japonia

 

Roboti umanoizi in Japonia

Filed under: Inventii — ivonachili @ 7:30 pm

A aparut versiunea feminina a robotului ciclist

Dupa ce, in urma cu trei ani, facea senzatie in expozitii Murata boy, robotul ciclist, japonezii de la Murata Manufacturing au pus la punct o versiune feminina a robotului, Murata girl. Ca orice versiune perfectionata, Murata girl este superioara varului ei, ea fiind capabila sa conduca un monociclu.

Murata girl, umanoidul-fetita, cantareste cinci kilograme si nu are nevoie de doua roti pentru a-si tine echilibrul, precum varul ei, cu trei ani mai varstnic, informeaza „Daily Mail”. Micul robot este dotat cu niste senzori care ii permit sa sesizeze eventualele obstacole din calea sa, permitandu-i sa schimbe directia.

Murata Girl va fi prezenta la expozitia CEATEC Japan 2008, care se va desfasura din 30 septembrie in orasul japonez Makuhari Messe.

 

Robot controlat cu un creier de maimuta

 

Oamenii de stiinta din Japonia au reusit sa controleze un robot umanoid cu semnale din creierul unei maimute, transmise prin internet din Statele Unite, anunta ITworld.com.

In cadrul experimentului, oamenii de stiinta de la Duke University in North Carolina, condusi de Miguel Nicolelis, au antrenat doua maimute sa mearga pe o banda de alergat. Activitatea neuronilor din creierul maimutelor, in zona aferenta picioarelor, a fost inregistrata in timpul mersului maimutelor si decodata sub forma unor predictii ale pozitiilor picioarelor.

Aceste informatii au fost trimise prin internet la Kyoto unde au fost folosite pentru a controla robotul.

Robotul, numit CBi (Computational Brain interface) este aproape de marimea unui om, cantareste 85 de kilograme si dispune de 51 de grade, libertate de miscare. A fost construit de catre Christopher Atkeson de la Institutul de Robotica al Carnegie Mellon University pentru a fi folosit in cercetari specifice neurostiintelor.

Aceasta cercetare, prima in genul ei, poate reprezenta primul pas catre refacerea functiilor motorii in cazuri de paralizie.

 

C.m.m.d.c Noiembrie 13, 2010

Filed under: Informatica — ivonachili @ 7:09 pm

Cel mai mic divizor comun

1.Enunt:

Se dau 2 numere.Se cere sa se determine cel mai mare divisor comun al lor.

2.Ex:

A B
90 42
48 42
6 42
6 36
6 30
6 24
6 18
6 12
6 6

Cmmdc(90,42)=6

Cmmdc(90,0)=90

Cmmdc(0,80)=80

a=0 =>cmmdc=b

b=0 =>cmmdc=a

a*b=0 => cmmdc=a+b

3.Algoritm:

-citim a,b;

-daca a*b=0 scrie a+b, altfel cat timp a!=b executa daca a>b atunci din a scadem pe b, altfel din b scadem pe a;

4.Pseudocod:

Start

Citeste a,b

Daca a*b=0 atunci scrie a+b

Altfel cat timp a!=b executa daca a>b atunci a=a-b

altfel b=b-a

scrie a

stop

5.OBS:

a) Numerele se modifica.Daca vrem sa le pastram gtrebuie sa le facem o copie(x=a;y=b)

b)Algoritmul este lent din punct de vedere al timpului.